1. Miguel Leeuwe
  2. PowerServer Web
  3. Friday, 16 November 2018

Hi,

 

I'm running powerserver on a windows 2012 R2 VM.

(Almost) Every time I run the application, I have to go into the AEM to set 

Welcome > Application > PB Features > Registry Mode > [myApp]

to use the registry of the machine and not the emulation of Appeon.

I save every time, but for some reason this goes wrong all the time.

 

Is this a known bug or something?

 

cheers.

Accepted Answer
Miguel Leeuwe Accepted Answer Pending Moderation
0
Votes
Undo

Okay, it's clear now:

 

- when setting deployment basic settings in the configuration to "Both", every time you do a deploy, the AEM registry settings are being overwritten.

- if you go into AEM and change the registry setting and save, it only works until the next time you do a deploy.

So to solve the problem deploy to "web" only.

 

Thanks Chris for your interest.

 

 

Comment
There are no comments made yet.
  1. Sunday, 18 November 2018
  2. PowerServer Web
  3. # Permalink
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Miguel;

  1. Is this problem on PowerServer 2017 build 1858?
  2. Does this problem happen on your development PS?

Regards ... Chris

Comment
Hi Chris,

I'm not totally sure yet, but I think I've figured it out, having to do with the "Project type" you choose.

(It happened on my VM Windows 2012 R2, with 64 powerserver, which comes with powerbuilder 2017 R3 build 1858.)



I've not seen the error message the last few times that I compiled and ran the application. This is after having changed the configuration for project type to WEB only. (before, when having the problem constantly, It was set to "Both" for Web and Mobile deployment).



I still have to do some more test later on and will confirm is that's really solved the problem.

thanks,

regards,

Miguel
  1. Miguel Leeuwe
  2. Friday, 16 November 2018
There are no comments made yet.
  1. Friday, 16 November 2018
  2. PowerServer Web
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.