postgresql table owner


I am testing using the  postgresql database and if I try to create a table it uses "user_name.table_name" but I need to create the tables in "public".  In other DB's i would just log in as "dbo" and all would be well but postgresql wont let me use public as a login.

Question Tags: 


mike S answered postgresql table owner


Postgresql uses schemas similar to how oracle does.

So what you could do is create a schema and user with the same name and use that instead of public.  Then it won't qualify the database objects with the schema name.

also, if you will use stored procedure based datawindows make sure you turn on the 'strip parameter names' option, otherwise parameters won't work with stored funtions.


john.murphy_28409's picture

Thanks! This worked after a bit of trying. The username had uppercase so I made the schema the same. After I made the schema all lower it worked.

I don't think it's a good solution as it will make using DB's that I don't create a problem or using DB's with multiple users.

My problem now is that it wont let me create the primary key. I will post that if I can't figure it out.'s picture

you may want to read up on schemas in posgresql:

SET search_path TO myschema;

ALTER USER user_name SET search_path to myschema

these will set schema default to myschema for current session, and permanently respectively.  then you dont need to worry about qualifying objects with the schema name.  i havent tried that to see if it also works with dw painter


john.murphy_28409's picture

I tried this before I posted. I searched the entire C: and found 3 real files, a bunch of shortcuts and two references that had no path???? I changed the 3 files but it did not fix it.'s picture

there is also a setting in pbodb170.ini that you can add to the postgresql section:


If changing it doesn't work, then you updated only some of the ini files.  windows copies this to your local user settings directory.

It is a HUGE PITA to have to change this every time a new PB version comes out.  I wish appeon would add this to the ini file as part of the standard install.



Govinda Lopez's picture

Hi all,


What Mike said is true. You can read more about this here:



I will pass your suggestion to our engineering team as an enhancement request.