App Path no longer working for PB IDE after R2 or Windows Patch?

1
0
-1

I have entries in "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\pb..." for my PB IDE's (pb170.exe and pb125.exe). I installed R2 on the 6th and it seemed to work fine but I cannot recall if I ran my application through the IDE then. The next morning my PC went through a Win 10 Patch.  After coming back I was unable to run my app through the either IDE (PB 2017 and 12.5) because it could not find a DLL that we use.  I tracked it down to that the App Path is not being included when PB starts. If I Right-click and Run as Admin then the App Path will get used and my application will run.  This is only an issue with PB - other applications that use an App Path work just fine.

So, can someone validate that their App Path works? From what I can tell R2 or Patch has messed me up but I do not know which one.

Thanks,

Chris Craft

Question Tags: 

Answers

Marco Meoni answered App Path no longer working for PB IDE after R2 or Windows Patch?

1
0
-1

Hello Chris,
stated that app path with or without "..\WOW6432Node\....\PB170.exe" is just a matter of Windows' bitness (and you should not care too much or rely on for external DLLs), I dont think it is related to your actual problem:

"...I was unable to run my app through the either IDE (PB 2017 and 12.5) because it could not find a DLL that we use"

My understanding is that the PB IDE do start, but your desktop application eventually fails when loads a 3rd party DLL.
Is that a standard Win32 DLL that you load through usual external function declaration?
Just make sure it is somewhere in a Windows PATH that is common to both PB12 and PB2017 on your DEV machine (Shared\PowerBuilder can be a good choice as folder already in the system PATH) and in the actual application folder on your production machines.

Cheers,
Marco

Chris@FamousSoftware.com's picture

I have 2 directories - one holds DLL's and the other holds Graphics. I have always used the App Path for this (since PB 9) because I do not want these directories in the Windows PATH. When the EXE starts, Windows will query the registry for the App Path and then add it to the Path (You can see this in Process Explorer) but now it does not even query the registry for it. This has always worked until the R2 or Windows Patch. What is strange though is it is ONLY a problem with PB IDE which is why I am thinking it is something with R2.  My deployed PB application works just fine. The only way I get the App Path to add is to Right Click on the EXE and run it as Administrator but that causes other issue with mapped drives.

I am at a loss as to what happened.

Chris

Chris Craft answered App Path no longer working for PB IDE after R2 or Windows Patch?

1
0
-1

Well, I might be getting closer - I ran PB 12.5 on a Win 10 Version 1709 machine and found the App Path is not working there either. Looks like it is a Windows Update problem.

Is anyone running Win 10 Version 1709 with the following applied updates?

Feature update to Windows 10, version 1709

KB4074595
KB4041994
KB4056892

 

Chris

Chris Craft answered App Path no longer working for PB IDE after R2 or Windows Patch?

1
0
-1

Found the problem! Looks like the Win update can no longer load the App Path if it is greater than 259 characters.  I removed some entries that are duplicated in the System Path and everything is working now. Might be a question for Appeon is to why they get set in both places but at least I know what the issue is.

Chris Craft

Roland Smith answered App Path no longer working for PB IDE after R2 or Windows Patch?

1
0
-1

Chris,

I ran into the same exact problem. I added my images folder in RegEdit and it changed in both locations (WOW6432NODE and regular).

Here is my AppPath:

C:\Program Files (x86)\Appeon;
C:\Program Files (x86)\Appeon\PowerBuilder 17.0;
C:\Program Files (x86)\Appeon\Shared\PowerBuilder;
C:\Program Files\SQL Anywhere 12\Bin64;
C:\Users\Public\Documents\Appeon\PowerBuilder 17.0\Help;
 

The first folder has no files in it so no need to be in the path. Since the IDE is 32bit, having SA12\Bin64 in the path would be of no use.

 

 

Brad Mettee answered App Path no longer working for PB IDE after R2 or Windows Patch?

Chris@FamousSoftware.com's picture

Thanks Brad - I wonder if that setting was on prior to the update because my path has always been that long. I will check it out.